You need to upgrade your Flash Player.

SQUARE ENIX requires Macromedia Flash, version 9 or greater. Please click here to download.

Or, if you're absolutely positive you have Flash 9 or greater, click here to force the site to load.